summaryrefslogtreecommitdiff
path: root/dev-python/pafy/pafy-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pafy/pafy-9999.ebuild')
-rw-r--r--dev-python/pafy/pafy-9999.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pafy/pafy-9999.ebuild b/dev-python/pafy/pafy-9999.ebuild
new file mode 100644
index 000000000000..b9d61d9088ce
--- /dev/null
+++ b/dev-python/pafy/pafy-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/mps-youtube/pafy.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Python library to retrieve YouTube content and metadata"
+HOMEPAGE="http://np1.github.io/pafy/ https://pypi.python.org/pypi/pafy"
+
+LICENSE="LGPL-3"
+SLOT="0"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="net-misc/youtube-dl[${PYTHON_USEDEP}]"