summaryrefslogtreecommitdiff
path: root/dev-python/pafy/pafy-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pafy/pafy-9999.ebuild')
-rw-r--r--dev-python/pafy/pafy-9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/pafy/pafy-9999.ebuild b/dev-python/pafy/pafy-9999.ebuild
index 9b18f78eea05..f9627f434ce8 100644
--- a/dev-python/pafy/pafy-9999.ebuild
+++ b/dev-python/pafy/pafy-9999.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6} )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
inherit distutils-r1
if [[ ${PV} == "9999" ]] ; then
@@ -19,5 +20,4 @@ HOMEPAGE="https://pythonhosted.org/pafy/ https://pypi.org/project/pafy/"
LICENSE="LGPL-3"
SLOT="0"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="net-misc/youtube-dl[${PYTHON_USEDEP}]"