summaryrefslogtreecommitdiff
path: root/dev-python/osprofiler/osprofiler-2.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/osprofiler/osprofiler-2.6.0.ebuild')
-rw-r--r--dev-python/osprofiler/osprofiler-2.6.0.ebuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/dev-python/osprofiler/osprofiler-2.6.0.ebuild b/dev-python/osprofiler/osprofiler-2.6.0.ebuild
index bd5a2632fec9..0a9777cb8580 100644
--- a/dev-python/osprofiler/osprofiler-2.6.0.ebuild
+++ b/dev-python/osprofiler/osprofiler-2.6.0.ebuild
@@ -3,6 +3,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -15,10 +16,7 @@ SLOT="0"
KEYWORDS="amd64 ~arm64 x86"
IUSE=""
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]
-"
+DEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
RDEPEND="
>=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
>=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]