summaryrefslogtreecommitdiff
path: root/dev-python/oslo-sphinx/oslo-sphinx-3.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oslo-sphinx/oslo-sphinx-3.0.0.ebuild')
-rw-r--r--dev-python/oslo-sphinx/oslo-sphinx-3.0.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/oslo-sphinx/oslo-sphinx-3.0.0.ebuild b/dev-python/oslo-sphinx/oslo-sphinx-3.0.0.ebuild
new file mode 100644
index 000000000000..2e89b229f771
--- /dev/null
+++ b/dev-python/oslo-sphinx/oslo-sphinx-3.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1
+
+MY_PN="${PN//-/}"
+
+DESCRIPTION="OpenStack Sphinx Extensions and Theme"
+HOMEPAGE="http://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc x86"
+IUSE="doc"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
+ <dev-python/pbr-2.0[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=">=dev-python/requests-2.5.2[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}