summaryrefslogtreecommitdiff
path: root/dev-python/oslo-i18n/oslo-i18n-6.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oslo-i18n/oslo-i18n-6.1.0.ebuild')
-rw-r--r--dev-python/oslo-i18n/oslo-i18n-6.1.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/oslo-i18n/oslo-i18n-6.1.0.ebuild b/dev-python/oslo-i18n/oslo-i18n-6.1.0.ebuild
new file mode 100644
index 000000000000..a228c1b29aec
--- /dev/null
+++ b/dev-python/oslo-i18n/oslo-i18n-6.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Oslo i18n library"
+HOMEPAGE="
+ https://opendev.org/openstack/oslo.i18n/
+ https://github.com/openstack/oslo.i18n/
+ https://pypi.org/project/oslo.i18n/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-5.1.0-fix-py3.11.patch"
+)
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest