summaryrefslogtreecommitdiff
path: root/dev-python/oslo-context/oslo-context-2.21.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oslo-context/oslo-context-2.21.0.ebuild')
-rw-r--r--dev-python/oslo-context/oslo-context-2.21.0.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/oslo-context/oslo-context-2.21.0.ebuild b/dev-python/oslo-context/oslo-context-2.21.0.ebuild
deleted file mode 100644
index 19dcc5f416c1..000000000000
--- a/dev-python/oslo-context/oslo-context-2.21.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Helpers to maintain useful information about a request context"
-HOMEPAGE="https://pypi.org/project/oslo.context/"
-SRC_URI="mirror://pypi/${PN:0:1}/oslo.context/oslo.context-${PV}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
- >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
- )"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
-"
-
-S="${WORKDIR}/oslo.context-${PV}"
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-# This time half the doc files are missing; Do you want them?
-python_test() {
- nosetests tests/ || die "test failed under ${EPYTHON}"
-}