summaryrefslogtreecommitdiff
path: root/dev-python/oslo-config/oslo-config-9.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oslo-config/oslo-config-9.3.0.ebuild')
-rw-r--r--dev-python/oslo-config/oslo-config-9.3.0.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-python/oslo-config/oslo-config-9.3.0.ebuild b/dev-python/oslo-config/oslo-config-9.3.0.ebuild
deleted file mode 100644
index 8a5bbb36170a..000000000000
--- a/dev-python/oslo-config/oslo-config-9.3.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYPI_PN=${PN/-/.}
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Oslo Configuration API"
-HOMEPAGE="
- https://opendev.org/openstack/oslo.config/
- https://github.com/openstack/oslo.config/
- https://pypi.org/project/oslo.config/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/pbr-1.3[${PYTHON_USEDEP}]
- >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
- >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
- >=dev-python/rfc3986-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/pbr-1.3[${PYTHON_USEDEP}]
- test? (
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
- >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/requests-mock-1.5.0[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # broken by some dep upgrade
- sed -i -e '/DeprecationWarningTestsNoOsloLog/,$d' \
- oslo_config/tests/test_cfg.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x COLUMNS=80
- eunittest -b
-}