summaryrefslogtreecommitdiff
path: root/dev-python/oslo-cache
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oslo-cache')
-rw-r--r--dev-python/oslo-cache/Manifest2
-rw-r--r--dev-python/oslo-cache/oslo-cache-1.30.3.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/oslo-cache/Manifest b/dev-python/oslo-cache/Manifest
index 3ee6a00db173..04c53e4f8283 100644
--- a/dev-python/oslo-cache/Manifest
+++ b/dev-python/oslo-cache/Manifest
@@ -1,3 +1,5 @@
DIST oslo-cache-1.30.1.tar.gz 53406 BLAKE2B 1b518c7f7af4b95fc71f76567f8742de7c7ab520cf4a1943fc7ed7bd9f3dcfd4150f83774e507d4135c7b567e53c3beb79a0cf6295c23e23d88a49d9ce63d2ed SHA512 8ee8ef32d07e8112aa7280f541446d13b3bba90fc7314eee60972180b0382a413e02cfcffbdd5bf4313aa394a25265665579f43f702a4b3754dc00f50441ca38
+DIST oslo-cache-1.30.3.tar.gz 53116 BLAKE2B 0b63f828f61dd82b69efe7a6e345974c56b2e980d88f159dd7c3ba5484cd1e8f78a393a7f73a6f2152db1c30178a054e2f20d753a286a0cd8f7d83af7f623bf2 SHA512 3ab9842cd388a846fe9004b97364057245936b9af185ba0f68e6d6bcc750dd957eb873d45e686cddeec94fda6872b72e4549c71ebc9e1de4755504c2a138b85c
EBUILD oslo-cache-1.30.1.ebuild 1042 BLAKE2B 4d82c2dd4a0093367c89e2ce5b30ebf1143d72095ac1d8c269b36e64f4cb0e363951752cea9b394ec278711212f40a13cffc923f48ad9e85d3889cc041d27a51 SHA512 c6c825f55d65dc3150e4a5e8d325f54d127af5d573332e67ebe4c8c9e2a9fef1094dbd3da948e9890f345356d121c211bde3ca21fec0df9934aaaf8a4d318211
+EBUILD oslo-cache-1.30.3.ebuild 1044 BLAKE2B 79d39645f2b468e0d1329808882ae4b62acea6eb3fcf7aa2ba205d6892c25c8cc0aae7117bda7798d06d036e5047a0025c38a518769e2c3592b09b328b9d8e4c SHA512 d0a630a8c4426db273533583efeff4590fb8eea5339075484002418d2c85b71f02a0caa21e1af7e1071c279400eaf34184a6f95705dd4c1c8fa02c902533edc5
MISC metadata.xml 457 BLAKE2B 09e44ecf9952f5bfd930616506874014a267d8622daf6c22b3da4856d9f4bbedcb3e4e72285972da026f310c47973c0bb70c222292caf877d4f9ab6d5166955a SHA512 f98547e9de8c502afabf7c53409df90ec687159b5160c8ff2166acff4d6bce0fe69c8eec78d50f52919cd75733f44f82dea5f9cde362d22ed69200d332b9d6b7
diff --git a/dev-python/oslo-cache/oslo-cache-1.30.3.ebuild b/dev-python/oslo-cache/oslo-cache-1.30.3.ebuild
new file mode 100644
index 000000000000..71b251dd4d54
--- /dev/null
+++ b/dev-python/oslo-cache/oslo-cache-1.30.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo Caching around dogpile.cache"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/dogpile-cache-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.30.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.31.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}