summaryrefslogtreecommitdiff
path: root/dev-python/oslo-cache/oslo-cache-1.25.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oslo-cache/oslo-cache-1.25.0.ebuild')
-rw-r--r--dev-python/oslo-cache/oslo-cache-1.25.0.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/oslo-cache/oslo-cache-1.25.0.ebuild b/dev-python/oslo-cache/oslo-cache-1.25.0.ebuild
deleted file mode 100644
index 9f4447b6a1cf..000000000000
--- a/dev-python/oslo-cache/oslo-cache-1.25.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{4,5}} )
-
-inherit distutils-r1 vcs-snapshot
-
-MY_PN=${PN/-/.}
-
-DESCRIPTION="Oslo Caching around dogpile.cache"
-HOMEPAGE="https://launchpad.net/oslo"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
-"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/dogpile-cache-0.6.2[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-4.0.0[${PYTHON_USEDEP}]
- !~dev-python/oslo-config-4.3.0[${PYTHON_USEDEP}]
- !~dev-python/oslo-config-4.4.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
- !~dev-python/oslo-i18n-3.15.2[${PYTHON_USEDEP}]
- >=dev-python/oslo-log-3.22.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.20.0[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}