summaryrefslogtreecommitdiff
path: root/dev-python/olefile/olefile-0.46-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/olefile/olefile-0.46-r1.ebuild')
-rw-r--r--dev-python/olefile/olefile-0.46-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/olefile/olefile-0.46-r1.ebuild b/dev-python/olefile/olefile-0.46-r1.ebuild
new file mode 100644
index 000000000000..cf09eeb237d8
--- /dev/null
+++ b/dev-python/olefile/olefile-0.46-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package to parse, read and write Microsoft OLE2 files"
+HOMEPAGE="https://www.decalage.info/olefile"
+SRC_URI="https://github.com/decalage2/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_sphinx doc
+distutils_enable_tests unittest