summaryrefslogtreecommitdiff
path: root/dev-python/olefile/olefile-0.45.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/olefile/olefile-0.45.1.ebuild')
-rw-r--r--dev-python/olefile/olefile-0.45.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/olefile/olefile-0.45.1.ebuild b/dev-python/olefile/olefile-0.45.1.ebuild
new file mode 100644
index 000000000000..243f264d315f
--- /dev/null
+++ b/dev-python/olefile/olefile-0.45.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package to parse, read and write Microsoft OLE2 files"
+HOMEPAGE="https://www.decalage.info/olefile"
+SRC_URI="https://github.com/decalage2/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=""
+BDEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ if use doc; then
+ emake -C doc html
+ HTML_DOCS=( doc/_build/html/. )
+ fi
+
+}