summaryrefslogtreecommitdiff
path: root/dev-python/objgraph
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/objgraph')
-rw-r--r--dev-python/objgraph/Manifest5
-rw-r--r--dev-python/objgraph/files/objgraph-3.4.1-tests.patch57
-rw-r--r--dev-python/objgraph/objgraph-3.5.0-r1.ebuild46
-rw-r--r--dev-python/objgraph/objgraph-3.6.1.ebuild2
4 files changed, 2 insertions, 108 deletions
diff --git a/dev-python/objgraph/Manifest b/dev-python/objgraph/Manifest
index e2ca15c75f95..2cda44cb17f1 100644
--- a/dev-python/objgraph/Manifest
+++ b/dev-python/objgraph/Manifest
@@ -1,6 +1,3 @@
-AUX objgraph-3.4.1-tests.patch 2708 BLAKE2B 2b2c78340c1be1c60fe3b43a671b1fab07bcb58275d90f59fca9dcc8bebdd52f5d6ed69455f9135647b27ed64d3251cb7d7b5f3da4e7b394bf45a45791b73c73 SHA512 8d8a43bcb75141a5fa278871d7e4e3b2ba1dcb833967a347f334675d6fa1a510d7f9abbcae82419617fc593ca02e1708ff69d9b4babe1d23e08d24814f9b564b
-DIST objgraph-3.5.0.tar.gz 638591 BLAKE2B 7a0ee6c9ee1d8417f7b322f19a397ea2452ed592ebbc07afc1378e86b5bad3895ed2e4a20d92a5f4b0215f68fc7440f85852303585a3161497a85d41d4c4e550 SHA512 da29202871bad06f2caa9cc297e7bf9a15af4c89e23baf9c271764e0ce93ff9557cd5c21d0bf39b425713460dbe2dbc8468d70c6bfcc1c3ff8b1b4d4a7923858
DIST objgraph-3.6.1.tar.gz 759513 BLAKE2B 875a4027b79446302755d00296ce0ae59d267f3996f206c8319a93cc8d5f53a0f26cf4701047d3b03beb3906bc5d70c23cdecfc135204d9fd9fea55d85e07a65 SHA512 9a15340aedb31e849739ec0667fefb52f99a94244540a7e1c0387299ad5fbbde05521ea91b959bc96204c4a62f796183377c6031af9c6a67828a91939f15225a
-EBUILD objgraph-3.5.0-r1.ebuild 903 BLAKE2B d4ea4a95dfdc70be1e0b1b7fbe2a5c22662984420cf711ba211af299f0dab7383da2f23162cd69fc49cf23b093846fbfad2e56b2c9e8c56d33500c861be661d7 SHA512 ad800519baf980de1cab8df260a2737e0c46566f583bd62bcab6b7a95491b2ccb89766212c14a4f01728b905213b2526b9ab88babd038a2aade585baaca5f447
-EBUILD objgraph-3.6.1.ebuild 1281 BLAKE2B dcf18cb56a07feb76bd5673d526cba2ee341f91f9484d930fb5bf05e53bb44c33c22c0895090f3d6708df4114977ecb55cc3f9d2c78ec7721eda188f9a3f07e9 SHA512 9f771acdff1b185598340bcf9cdd54b2d9b66735ccc6f63e5876417cbbe256cb48d09339047a7d15f0cb03b63803511b5644473f98a990c9cbc0994022cb0150
+EBUILD objgraph-3.6.1.ebuild 1274 BLAKE2B f196e1a796c61c7a459e57261f0b58aa0a4b6d91ac3ff156a9b1aa8c638f37656b091a3fd7f42be0b7181a5440c4e5e41583d6cccf262d3d7d114a7d8a4e964a SHA512 68c023d8a0ac5d4459b6a228d5ce5d65730e04209ddf04c819a3bf4a99c7dfb399508a3a0fa8516ddb693b32330fa6ce6cdff191f9a96c347539a76021737849
MISC metadata.xml 514 BLAKE2B 3da44f63b9604c7f730f9efc543d102bd2660eea11faeb29c6977b5cecf647d15c3075a9a20e81f9e35b3f08b2d51d47a6c1b63d9928bb56c22baaf61f1ced15 SHA512 5521d5ac2053e45ee1c7fec6ae176956f5823c22c144b8bcbfb47c2ca29c6595abfe45a3fd90a9a058b927157a22196dc17b14c6832a685214c4d2ebbe59c959
diff --git a/dev-python/objgraph/files/objgraph-3.4.1-tests.patch b/dev-python/objgraph/files/objgraph-3.4.1-tests.patch
deleted file mode 100644
index d79b78fb88b5..000000000000
--- a/dev-python/objgraph/files/objgraph-3.4.1-tests.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-diff --git a/tests.py b/tests.py
-index fc2ee7f..d494470 100755
---- a/tests.py
-+++ b/tests.py
-@@ -11,6 +11,7 @@ import tempfile
- import textwrap
- import types
- import unittest
-+import platform
-
- # setuptools imports `imp`, which triggers a DeprecationWarning starting with
- # Python 3.4 in the middle of my pristine test suite. But if I do the import
-@@ -363,7 +364,7 @@ def doctest_get_new_ids_prints():
- ========================================================
- Type Old_ids Current_ids New_ids Count_Deltas
- ========================================================
-- list ... ... ... +2
-+ wt ... ... ... +2
- ========================================================
-
- """
-@@ -387,7 +388,10 @@ class ByTypeTest(GarbageCollectedMixin, unittest.TestCase):
- # 2. the `res` list
- # referrers we don't want:
- # the ``objects`` list in the now-dead stack frame of objgraph.by_type
-- self.assertLessEqual(len(gc.get_referrers(res[0])), 2)
-+ if 'pypy' in platform.python_implementation().lower():
-+ self.assertLessEqual(len(gc.get_referrers(res[0])), 3)
-+ else:
-+ self.assertLessEqual(len(gc.get_referrers(res[0])), 2)
-
-
- class AtAddrsTest(unittest.TestCase):
-@@ -439,7 +443,10 @@ class StringRepresentationTest(GarbageCollectedMixin,
- obj = MyClass()
- with mock.patch.object(obj, 'my_method',
- types.MethodType(mock_method, obj)):
-- self.assertRegex(objgraph._short_repr(obj.my_method), '<Mock')
-+ if 'pypy' in platform.python_implementation().lower():
-+ self.assertRegex(objgraph._short_repr(obj.my_method), '<bound method')
-+ else:
-+ self.assertRegex(objgraph._short_repr(obj.my_method), '<Mock')
-
- def test_short_repr_mocked_name(self):
- self.assertRegex(objgraph._short_repr(mock.Mock(__name__=mock.Mock())),
-@@ -462,7 +469,10 @@ class StringRepresentationTest(GarbageCollectedMixin,
- obj = MyClass()
- with mock.patch.object(obj, 'my_method',
- types.MethodType(mock_method, obj)):
-- self.assertRegex(objgraph._short_repr(obj.my_method), '<Mock')
-+ if 'pypy' in platform.python_implementation().lower():
-+ self.assertRegex(objgraph._short_repr(obj.my_method), '<bound method')
-+ else:
-+ self.assertRegex(objgraph._short_repr(obj.my_method), '<Mock')
-
- @skipIf(sys.version_info[0] > 2, "Python 3 has no unbound methods")
- def test_short_repr_unbound_method(self):
diff --git a/dev-python/objgraph/objgraph-3.5.0-r1.ebuild b/dev-python/objgraph/objgraph-3.5.0-r1.ebuild
deleted file mode 100644
index 4f3489261c53..000000000000
--- a/dev-python/objgraph/objgraph-3.5.0-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Draws Python object reference graphs with graphviz"
-HOMEPAGE="
- https://github.com/mgedmin/objgraph/
- https://pypi.org/project/objgraph/
-"
-
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="doc"
-
-RDEPEND="
- media-gfx/graphviz
-"
-BDEPEND="
- test? (
- media-gfx/xdot
- )
-"
-
-PATCHES=(
- "${FILESDIR}/objgraph-3.4.1-tests.patch"
-)
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # the dependency is optional, actually
- sed -i -e '/graphviz/d' setup.py || die
- distutils-r1_src_prepare
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/* )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/objgraph/objgraph-3.6.1.ebuild b/dev-python/objgraph/objgraph-3.6.1.ebuild
index bcd79608beac..c9d284359d22 100644
--- a/dev-python/objgraph/objgraph-3.6.1.ebuild
+++ b/dev-python/objgraph/objgraph-3.6.1.ebuild
@@ -15,8 +15,8 @@ HOMEPAGE="
"
LICENSE="MIT"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="doc"
RDEPEND="