summaryrefslogtreecommitdiff
path: root/dev-python/objgraph/objgraph-3.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/objgraph/objgraph-3.5.0.ebuild')
-rw-r--r--dev-python/objgraph/objgraph-3.5.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/objgraph/objgraph-3.5.0.ebuild b/dev-python/objgraph/objgraph-3.5.0.ebuild
new file mode 100644
index 000000000000..52a0b40de5d0
--- /dev/null
+++ b/dev-python/objgraph/objgraph-3.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Draws Python object reference graphs with graphviz"
+HOMEPAGE="https://mg.pov.lt/objgraph/"
+SRC_URI="mirror://pypi/o/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="amd64 arm arm64 ~ia64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="media-gfx/graphviz"
+BDEPEND="test? ( media-gfx/xdot )"
+
+PATCHES=(
+ "${FILESDIR}/objgraph-3.4.1-tests.patch"
+)
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/* )
+ distutils-r1_python_install_all
+}