summaryrefslogtreecommitdiff
path: root/dev-python/oauthlib/oauthlib-3.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oauthlib/oauthlib-3.2.1.ebuild')
-rw-r--r--dev-python/oauthlib/oauthlib-3.2.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/oauthlib/oauthlib-3.2.1.ebuild b/dev-python/oauthlib/oauthlib-3.2.1.ebuild
new file mode 100644
index 000000000000..c9f783b21010
--- /dev/null
+++ b/dev-python/oauthlib/oauthlib-3.2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Spec-compliant and thorough implementation of the OAuth request-signing logic"
+HOMEPAGE="https://github.com/oauthlib/oauthlib https://pypi.org/project/oauthlib/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+# optional extras hard set as RDEPs. See setup.py
+RDEPEND="
+ >=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest