summaryrefslogtreecommitdiff
path: root/dev-python/numpydoc
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/numpydoc')
-rw-r--r--dev-python/numpydoc/Manifest2
-rw-r--r--dev-python/numpydoc/numpydoc-1.6.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/numpydoc/Manifest b/dev-python/numpydoc/Manifest
index e7d89682fe04..31590fdbe8a2 100644
--- a/dev-python/numpydoc/Manifest
+++ b/dev-python/numpydoc/Manifest
@@ -1,3 +1,5 @@
DIST numpydoc-1.5.0.gh.tar.gz 71498 BLAKE2B 6f46d3b39ceecffe1a604d314bb0b2613219c92a951e3578333da8c0891e928564dd7501258d0270901b9923be7caf8af5d68ed4df7dd8f8e322a7503456fbf7 SHA512 e87535c74767946a71b3094b6591fcfb4d7e42acd505c28b3a5c00ea19c29bb21806c5cb655b5d3aca670d105654956d9b59c06d8be68cd51a1760b219c1c815
+DIST numpydoc-1.6.0.gh.tar.gz 85296 BLAKE2B 839fb0062dc1b0b45dfbc855d50d21a3c23cf1e9fef82b8d44e9d4cc36127c32447ad4c6ee5aa500cd24fb6a304f95426be69406468e3059c068ca4b0ad5714f SHA512 3846f395d8603a21d97a6c0fc57f0ea69e908ff2f672673d336a1f4ff02f5cb3f9e76d1e1ad6d990478b121a327bcca8179c3db6b5215f36818e41e4597878fd
EBUILD numpydoc-1.5.0.ebuild 1128 BLAKE2B 7f17e6d14f9b4340db08f2598d4c4aa54b8ea622c10f19284997953ce9fe6bb877b66278e9dc2ba1f4feba006346e6870f239b48f46e025b9af38e152285754d SHA512 9454280ea5a09e8a112246a9e3cc177e4e9873478ca4df7f811ef6a7be1d557419da138fac68d7af72fa929207e3ccadd4dae89953559b3e9b0a76ac3c8f49ab
+EBUILD numpydoc-1.6.0.ebuild 1159 BLAKE2B 1eeab0e971522aa3ccbb30a1bad0d44a4b1d737fa2e4477d9eda11b1461218c5e9abd81a3f0269f8ce711fab9cee51bb1a7a999b29e51fe8f66f790a0e653415 SHA512 66b4d5207b06c6181f6c66fc715579fe8827a149bfaca317d1107956584a3a2056d035bd35f16b04b887e788752c6bba6410209c8b254b0c8786aa8c947f62fc
MISC metadata.xml 403 BLAKE2B 437fdd3881a5ec60a83b3cb018e57c714a91030be9ab0032b8662e30b7bcd120ee3dd2015be561dd8a65a39833ef777e22f040a6e466c1b56a602a4ac33d4917 SHA512 833d00712cf7dfdc1080181301c03388a3c966436d2d9c9badb609cff66fa49035a6d001d60f205e1c2c49808eda7fad65abda8802f42f7ba36939b3691a8390
diff --git a/dev-python/numpydoc/numpydoc-1.6.0.ebuild b/dev-python/numpydoc/numpydoc-1.6.0.ebuild
new file mode 100644
index 000000000000..2955338caaea
--- /dev/null
+++ b/dev-python/numpydoc/numpydoc-1.6.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to support docstrings in Numpy format"
+HOMEPAGE="
+ https://numpydoc.readthedocs.io/en/latest/
+ https://github.com/numpy/numpydoc/
+ https://pypi.org/project/numpydoc/
+"
+SRC_URI="
+ https://github.com/numpy/numpydoc/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/jinja-2.10[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.10[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/matplotlib-3.2.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # these require Internet (intersphinx)
+ numpydoc/tests/test_full.py::test_MyClass
+ numpydoc/tests/test_full.py::test_my_function
+ )
+ epytest -o addopts= --pyargs numpydoc
+}