summaryrefslogtreecommitdiff
path: root/dev-python/numpydoc/numpydoc-1.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/numpydoc/numpydoc-1.6.0.ebuild')
-rw-r--r--dev-python/numpydoc/numpydoc-1.6.0.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/numpydoc/numpydoc-1.6.0.ebuild b/dev-python/numpydoc/numpydoc-1.6.0.ebuild
index d83cce3a7d06..dcd8259986f6 100644
--- a/dev-python/numpydoc/numpydoc-1.6.0.ebuild
+++ b/dev-python/numpydoc/numpydoc-1.6.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -37,6 +37,11 @@ BDEPEND="
)
"
+PATCHES=(
+ # https://github.com/numpy/numpydoc/pull/523
+ "${FILESDIR}/${P}-py3.12-flt-depr-warn.patch"
+)
+
distutils_enable_tests pytest
python_test() {