summaryrefslogtreecommitdiff
path: root/dev-python/nspektr/nspektr-0.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nspektr/nspektr-0.3.0.ebuild')
-rw-r--r--dev-python/nspektr/nspektr-0.3.0.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/nspektr/nspektr-0.3.0.ebuild b/dev-python/nspektr/nspektr-0.3.0.ebuild
deleted file mode 100644
index e263862fc659..000000000000
--- a/dev-python/nspektr/nspektr-0.3.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Distribution package dependency inspector"
-HOMEPAGE="
- https://github.com/jaraco/nspektr/
- https://pypi.org/project/nspektr/
-"
-SRC_URI="
- https://github.com/jaraco/nspektr/archive/v${PV}.tar.gz
- -> ${P}.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-RDEPEND="
- >=dev-python/jaraco-context-4.1.1-r2[${PYTHON_USEDEP}]
- >=dev-python/jaraco-functools-3.5.0-r2[${PYTHON_USEDEP}]
- >=dev-python/more-itertools-8.12.0-r1[${PYTHON_USEDEP}]
- >=dev-python/packaging-21.3-r2[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/importlib_metadata-4.11.2[${PYTHON_USEDEP}]
- ' 3.8 3.9)
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # avoid unnecessary test dep on pip
- sed -i -e 's:pip:pytest:' nspektr/__init__.py || die
- distutils-r1_src_prepare
-}
-
-src_configure() {
- grep -q 'build-backend = "setuptools' pyproject.toml ||
- die "Upstream changed build-backend, recheck"
- # write a custom pyproject.toml to ease setuptools bootstrap
- cat > pyproject.toml <<-EOF || die
- [build-system]
- requires = ["flit_core >=3.2,<4"]
- build-backend = "flit_core.buildapi"
-
- [project]
- name = "nspektr"
- version = "${PV}"
- description = "package inspector"
-
- # tests inspect itself
- [project.optional-dependencies]
- docs = [
- "fake-nonexisting",
- ]
- testing = [
- "pytest",
- ]
- EOF
-}