summaryrefslogtreecommitdiff
path: root/dev-python/notify2/notify2-0.3.1-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/notify2/notify2-0.3.1-r3.ebuild')
-rw-r--r--dev-python/notify2/notify2-0.3.1-r3.ebuild25
1 files changed, 16 insertions, 9 deletions
diff --git a/dev-python/notify2/notify2-0.3.1-r3.ebuild b/dev-python/notify2/notify2-0.3.1-r3.ebuild
index 763d993a1b97..1ce93e8a0361 100644
--- a/dev-python/notify2/notify2-0.3.1-r3.ebuild
+++ b/dev-python/notify2/notify2-0.3.1-r3.ebuild
@@ -4,25 +4,32 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 virtualx pypi
DESCRIPTION="Python interface to DBus notifications"
-HOMEPAGE="https://bitbucket.org/takluyver/pynotify2"
+HOMEPAGE="
+ https://bitbucket.org/takluyver/pynotify2/
+ https://pypi.org/project/notify2/
+"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv x86"
IUSE="examples"
-RDEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]"
-BDEPEND="test? (
- dev-python/pygobject[${PYTHON_USEDEP}]
- sys-apps/dbus[X]
- x11-libs/gdk-pixbuf[introspection]
- virtual/notification-daemon
-)"
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ sys-apps/dbus[X]
+ x11-libs/gdk-pixbuf[introspection]
+ virtual/notification-daemon
+ )
+"
distutils_enable_tests unittest