summaryrefslogtreecommitdiff
path: root/dev-python/noseofyeti/noseofyeti-2.4.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/noseofyeti/noseofyeti-2.4.8.ebuild')
-rw-r--r--dev-python/noseofyeti/noseofyeti-2.4.8.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/noseofyeti/noseofyeti-2.4.8.ebuild b/dev-python/noseofyeti/noseofyeti-2.4.8.ebuild
new file mode 100644
index 000000000000..97c4ffc90e9f
--- /dev/null
+++ b/dev-python/noseofyeti/noseofyeti-2.4.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A custom python codec that provides an RSpec style dsl for python"
+HOMEPAGE="
+ https://github.com/delfick/nose-of-yeti/
+ https://pypi.org/project/noseOfYeti/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires alt-pytest-asyncio
+ tests/test_using_pytest.py::TestPyTest::test_it_collects_tests_correctly
+)