summaryrefslogtreecommitdiff
path: root/dev-python/nose2/nose2-0.12.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nose2/nose2-0.12.0.ebuild')
-rw-r--r--dev-python/nose2/nose2-0.12.0.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/nose2/nose2-0.12.0.ebuild b/dev-python/nose2/nose2-0.12.0.ebuild
deleted file mode 100644
index 6b06afa556b8..000000000000
--- a/dev-python/nose2/nose2-0.12.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Next generation unittest with plugins"
-HOMEPAGE="
- https://github.com/nose-devs/nose2/
- https://pypi.org/project/nose2/
-"
-SRC_URI="
- https://github.com/nose-devs/${PN}/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ppc ppc64 ~sparc x86"
-
-RDEPEND="
- >=dev-python/coverage-4.4.1[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx-rtd-theme \
- dev-python/sphinx-issues
-
-PATCHES=(
- "${FILESDIR}"/${P}-version.patch
-)
-
-src_prepare() {
- # seriously? that hard to depend on six?!
- rm -r nose2/_vendor || die
- find -name '*.py' -exec \
- sed -i -e 's:from nose2._vendor ::' {} + || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- "${EPYTHON}" -m nose2.__main__ -vv || die "tests failed under ${EPYTHON}"
-}