summaryrefslogtreecommitdiff
path: root/dev-python/nose-testconfig/nose-testconfig-0.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nose-testconfig/nose-testconfig-0.9.ebuild')
-rw-r--r--dev-python/nose-testconfig/nose-testconfig-0.9.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/nose-testconfig/nose-testconfig-0.9.ebuild b/dev-python/nose-testconfig/nose-testconfig-0.9.ebuild
new file mode 100644
index 000000000000..778020be628b
--- /dev/null
+++ b/dev-python/nose-testconfig/nose-testconfig-0.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Test Configuration plugin for nosetests"
+HOMEPAGE="https://bitbucket.org/jnoller/nose-testconfig"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="dev-python/nose"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DOCS=( docs/index.txt )
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}