summaryrefslogtreecommitdiff
path: root/dev-python/node-semver/node-semver-0.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/node-semver/node-semver-0.9.0.ebuild')
-rw-r--r--dev-python/node-semver/node-semver-0.9.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/node-semver/node-semver-0.9.0.ebuild b/dev-python/node-semver/node-semver-0.9.0.ebuild
new file mode 100644
index 000000000000..eae865fa5850
--- /dev/null
+++ b/dev-python/node-semver/node-semver-0.9.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Python version of node-semver, the semantic versioner for npm"
+HOMEPAGE="
+ https://pypi.org/project/node-semver/
+ https://github.com/podhmo/python-node-semver/
+ https://github.com/npm/node-semver/
+"
+SRC_URI="
+ https://github.com/podhmo/python-node-semver/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest