summaryrefslogtreecommitdiff
path: root/dev-python/nnpy/nnpy-1.4.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nnpy/nnpy-1.4.2-r1.ebuild')
-rw-r--r--dev-python/nnpy/nnpy-1.4.2-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/nnpy/nnpy-1.4.2-r1.ebuild b/dev-python/nnpy/nnpy-1.4.2-r1.ebuild
new file mode 100644
index 000000000000..9264d39a5665
--- /dev/null
+++ b/dev-python/nnpy/nnpy-1.4.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="cffi-based Python bindings for nanomsg"
+HOMEPAGE="
+ https://github.com/nanomsg/nnpy/
+ https://pypi.org/project/nnpy/
+"
+SRC_URI="
+ https://github.com/nanomsg/nnpy/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+
+DEPEND="
+ dev-python/cffi:=[${PYTHON_USEDEP}]
+ dev-libs/nanomsg:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests unittest