summaryrefslogtreecommitdiff
path: root/dev-python/netaddr/netaddr-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/netaddr/netaddr-1.1.0.ebuild')
-rw-r--r--dev-python/netaddr/netaddr-1.1.0.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/netaddr/netaddr-1.1.0.ebuild b/dev-python/netaddr/netaddr-1.1.0.ebuild
deleted file mode 100644
index 719767e4cca7..000000000000
--- a/dev-python/netaddr/netaddr-1.1.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Network address representation and manipulation library"
-HOMEPAGE="
- https://github.com/netaddr/netaddr/
- https://pypi.org/project/netaddr/
- https://netaddr.readthedocs.io/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
-IUSE="cli"
-
-RDEPEND="
- cli? ( dev-python/ipython[${PYTHON_USEDEP}] )
-"
-
-distutils_enable_sphinx docs/source \
- dev-python/furo \
- dev-python/sphinx-issues
-distutils_enable_tests pytest
-
-src_prepare() {
- if ! use cli; then
- sed -i -e '/netaddr\.cli/d' pyproject.toml || die
- fi
-
- distutils-r1_src_prepare
-}