summaryrefslogtreecommitdiff
path: root/dev-python/nest_asyncio/nest_asyncio-1.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nest_asyncio/nest_asyncio-1.5.1.ebuild')
-rw-r--r--dev-python/nest_asyncio/nest_asyncio-1.5.1.ebuild27
1 files changed, 0 insertions, 27 deletions
diff --git a/dev-python/nest_asyncio/nest_asyncio-1.5.1.ebuild b/dev-python/nest_asyncio/nest_asyncio-1.5.1.ebuild
deleted file mode 100644
index cd229300b86e..000000000000
--- a/dev-python/nest_asyncio/nest_asyncio-1.5.1.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Patch asyncio to allow nested event loops"
-HOMEPAGE="https://github.com/erdewit/nest_asyncio/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=()
- [[ ${EPYTHON} == python3.10 ]] && deselect+=(
- # incorrect args in test itself
- tests/nest_test.py::NestTest::test_two_run_until_completes_in_one_outer_loop
- )
- epytest ${deselect[@]/#/--deselect }
-}