summaryrefslogtreecommitdiff
path: root/dev-python/neovim-remote
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/neovim-remote')
-rw-r--r--dev-python/neovim-remote/Manifest4
-rw-r--r--dev-python/neovim-remote/metadata.xml5
-rw-r--r--dev-python/neovim-remote/neovim-remote-1.8.6.ebuild26
-rw-r--r--dev-python/neovim-remote/neovim-remote-9999.ebuild26
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/neovim-remote/Manifest b/dev-python/neovim-remote/Manifest
new file mode 100644
index 000000000000..6de9a9f1e46f
--- /dev/null
+++ b/dev-python/neovim-remote/Manifest
@@ -0,0 +1,4 @@
+DIST neovim-remote-1.8.6.tar.gz 434012 BLAKE2B 1fddb5e4376d3d17c2ff0c00e5f98700ab2d221af1ed1bc3f9c6dabe9cf1bdafe9f85041cb3a01f9a45f03df2d76bc0ae3c5a93603caa9ad461eb5ae50cb832f SHA512 b973b8c495a3a371b9a21ec4110beebbfe304f00d73aaf1da849df612e6ea9a08258379600ccb8d83154b8ef12e26088ba90a1668c5262b7dc9c62c844f42798
+EBUILD neovim-remote-1.8.6.ebuild 667 BLAKE2B 8d5583fd913fff3f0883abc5c5b77fd1061bb4bcc60dd305f4053759b3ca1bdaee7b93c773d6a3d62970e19e1fc3276457918816796c2c58e5b1d1d9aec1d560 SHA512 c8aa7bf991906b7a61cf0b5b307289232974d9053d01cd25c6298c8a77c8de286b9d7a141977893301147a16dd402a082effac472144d4ba320db584abf151d2
+EBUILD neovim-remote-9999.ebuild 667 BLAKE2B 8d5583fd913fff3f0883abc5c5b77fd1061bb4bcc60dd305f4053759b3ca1bdaee7b93c773d6a3d62970e19e1fc3276457918816796c2c58e5b1d1d9aec1d560 SHA512 c8aa7bf991906b7a61cf0b5b307289232974d9053d01cd25c6298c8a77c8de286b9d7a141977893301147a16dd402a082effac472144d4ba320db584abf151d2
+MISC metadata.xml 168 BLAKE2B 95e3160d1d6abb3e5510581fe45ddcd9ad526f89bbc0d3ad226e2782d148a0c71e50426809a87fb45e6fc9356e597a1d271002764caebc79be8846301eb82d5e SHA512 5edd6cda32972ff5e53cf5f883928bd1887b4a45572657f99101284a909ea04ff906b8f4068d247d1b3367bde813dbb37ba11565aaff880d9b500685b0f5a33d
diff --git a/dev-python/neovim-remote/metadata.xml b/dev-python/neovim-remote/metadata.xml
new file mode 100644
index 000000000000..585b0dc75dda
--- /dev/null
+++ b/dev-python/neovim-remote/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ </pkgmetadata>
diff --git a/dev-python/neovim-remote/neovim-remote-1.8.6.ebuild b/dev-python/neovim-remote/neovim-remote-1.8.6.ebuild
new file mode 100644
index 000000000000..a6aa978b3b88
--- /dev/null
+++ b/dev-python/neovim-remote/neovim-remote-1.8.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mhinz/${PN}.git"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/mhinz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="A tool that helps control neovim processes"
+HOMEPAGE="https://github.com/mhinz/neovim-remote"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/neovim-python-client[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/neovim-remote/neovim-remote-9999.ebuild b/dev-python/neovim-remote/neovim-remote-9999.ebuild
new file mode 100644
index 000000000000..a6aa978b3b88
--- /dev/null
+++ b/dev-python/neovim-remote/neovim-remote-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mhinz/${PN}.git"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/mhinz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="A tool that helps control neovim processes"
+HOMEPAGE="https://github.com/mhinz/neovim-remote"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/neovim-python-client[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"