summaryrefslogtreecommitdiff
path: root/dev-python/neovim-remote/neovim-remote-2.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/neovim-remote/neovim-remote-2.1.0.ebuild')
-rw-r--r--dev-python/neovim-remote/neovim-remote-2.1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/neovim-remote/neovim-remote-2.1.0.ebuild b/dev-python/neovim-remote/neovim-remote-2.1.0.ebuild
new file mode 100644
index 000000000000..d77fc60b85e8
--- /dev/null
+++ b/dev-python/neovim-remote/neovim-remote-2.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mhinz/${PN}.git"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/mhinz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="A tool that helps control neovim processes"
+HOMEPAGE="https://github.com/mhinz/neovim-remote"
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/neovim-python-client[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ pytest -vv || die
+}