summaryrefslogtreecommitdiff
path: root/dev-python/neovim-python-client/neovim-python-client-0.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/neovim-python-client/neovim-python-client-0.2.0.ebuild')
-rw-r--r--dev-python/neovim-python-client/neovim-python-client-0.2.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/neovim-python-client/neovim-python-client-0.2.0.ebuild b/dev-python/neovim-python-client/neovim-python-client-0.2.0.ebuild
new file mode 100644
index 000000000000..66a5585d620d
--- /dev/null
+++ b/dev-python/neovim-python-client/neovim-python-client-0.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for Neovim"
+HOMEPAGE="https://github.com/neovim/python-client"
+SRC_URI="https://github.com/neovim/python-client/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-python/msgpack-0.4.0[${PYTHON_USEDEP}]
+ virtual/python-greenlet[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python{2_7,3_3})"
+
+RDEPEND="
+ ${DEPEND}
+ app-editors/neovim"
+
+S="${WORKDIR}/python-client-${PV}"