summaryrefslogtreecommitdiff
path: root/dev-python/nbformat
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nbformat')
-rw-r--r--dev-python/nbformat/Manifest2
-rw-r--r--dev-python/nbformat/nbformat-5.10.2.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/nbformat/Manifest b/dev-python/nbformat/Manifest
index 0f114a9eb6c0..9bbec4696b67 100644
--- a/dev-python/nbformat/Manifest
+++ b/dev-python/nbformat/Manifest
@@ -1,4 +1,6 @@
AUX nbformat-5.7.1-no-node.patch 719 BLAKE2B d9a30c5cc917f6056e73a90f2300d15aa57d666f79d7185fed2ba092438c00f0bda307b1f0e4d2ca1429bf17a8a44475847aa98292c94fa5bcb911d868fcadab SHA512 2b52e2bf94155460f7963037119078301ed96d6b838d0f639f4775d6b10ee73ab05ebdc381eb020fdab01517f9b92d32dd2f45d7d614e783c221da937e4cb3dc
+DIST nbformat-5.10.2.tar.gz 142443 BLAKE2B 7089b27f2ed05e2240e12f583ed6d73aeace54939f235cdd41dede0f410a15927dd4223af0f9a8072bdaef15c3c737941c69313ee27abf69784df302677624b1 SHA512 a68e3261bd5a3126bb31a99fce3e85daad3651a39844f1fadf499c25af76b3b544188a7ece4d248534c4b3f3d3eca7a1caff17f0beaec9b866e989e76c666316
DIST nbformat-5.9.2.tar.gz 141264 BLAKE2B 71f5bb447d675b10276565cb53ac193963e5161fd27e925d639e7aa63f1e69db8903974d2f924ad5456940c4b904aba33d8ab10772fdb70e7e67974a90d1f3d6 SHA512 886a03cf95b39cdca48ae46d4946cee0f3dc1f5fa0e9dac7c6184b4c3e326adb739bd9da28032868a973577aa949feb5ae95a84017755948610ef7f208ebc5db
+EBUILD nbformat-5.10.2.ebuild 1128 BLAKE2B b1f753d3d7865ae3d04228b1cf8da236d516d528b9647de425b07de6021ba9b5f08ca5f58dd73abf0d6b7a00dcc73907e30987ec3fdfc350bd5a4b2c23b38b4e SHA512 ea9dbe3f0c239416ee2a28479bb332863503fa06fc486b6b16535a1b34e028fdf32e0312ad727c224a0b1955887b42eb54bd9017422aa0d2d8ee9c32cfb0d751
EBUILD nbformat-5.9.2.ebuild 1068 BLAKE2B e06c15353ca0b30099b3a3eeea458e269ef16aa76e0b18003f72532a69f9249fbf1db67bdeb753785bc4f5977e388e206daab9db0db99dd1cfdd5f4340a60f1f SHA512 7155e25fd464fc745ca8edafbf62671c4a4abbca718f5bb917e252c8b7eca50a9edae2d4e50ce3eb85107029f27d3de9cff335a926cf62c91f2eb944b63c5e0c
MISC metadata.xml 780 BLAKE2B d44b94d8d10d01e2b8f465b6a0351308e7c219295f34713ea2f26f0cc1c9ee4c156bae3a33977a8adc0bd2cef177d468a5221d0d7a5bce946bcd3aa1a1ff0623 SHA512 0d15f8e0ef1d3f675cfabd0a9d4db7a8844be4ae1c9ff06825bc9a0771ef7e2430d1ff66a3ded9ee64df42ab4277c3eba65ed256d6a672cad20154272a0a2c96
diff --git a/dev-python/nbformat/nbformat-5.10.2.ebuild b/dev-python/nbformat/nbformat-5.10.2.ebuild
new file mode 100644
index 000000000000..0bf953fb87b2
--- /dev/null
+++ b/dev-python/nbformat/nbformat-5.10.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Reference implementation of the Jupyter Notebook format"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/nbformat/
+ https://pypi.org/project/nbformat/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/fastjsonschema[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.6[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.1[${PYTHON_USEDEP}]
+ dev-python/jupyter-core[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/pydata-sphinx-theme \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/sphinxcontrib-spelling
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/nbformat-5.7.1-no-node.patch"
+)
+
+EPYTEST_IGNORE=(
+ # requires pep440 package, which is not really relevant for us
+ tests/test_api.py
+)