summaryrefslogtreecommitdiff
path: root/dev-python/nbconvert/nbconvert-6.0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nbconvert/nbconvert-6.0.7.ebuild')
-rw-r--r--dev-python/nbconvert/nbconvert-6.0.7.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/dev-python/nbconvert/nbconvert-6.0.7.ebuild b/dev-python/nbconvert/nbconvert-6.0.7.ebuild
index a7ec918819d1..578ce6abca48 100644
--- a/dev-python/nbconvert/nbconvert-6.0.7.ebuild
+++ b/dev-python/nbconvert/nbconvert-6.0.7.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..9} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Converting Jupyter Notebooks"
@@ -54,9 +52,9 @@ python_test() {
local deselect=(
# Missing pyppeteer for now
# TODO: Doesn't skip?
- --deselect exporters/tests/test_webpdf.py
+ --deselect nbconvert/exporters/tests/test_webpdf.py
# Needs pyppeteer too
- --deselect 'tests/test_nbconvertapp.py::TestNbConvertApp::test_webpdf_with_chromium'
+ --deselect 'nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_webpdf_with_chromium'
)
distutils_install_for_testing bdist_egg