summaryrefslogtreecommitdiff
path: root/dev-python/nbclassic/nbclassic-0.4.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nbclassic/nbclassic-0.4.5.ebuild')
-rw-r--r--dev-python/nbclassic/nbclassic-0.4.5.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/nbclassic/nbclassic-0.4.5.ebuild b/dev-python/nbclassic/nbclassic-0.4.5.ebuild
new file mode 100644
index 000000000000..b3849a53b10d
--- /dev/null
+++ b/dev-python/nbclassic/nbclassic-0.4.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=jupyter
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Notebook as a Jupyter Server Extension"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/nbclassic/
+ https://pypi.org/project/nbclassic/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/jupyter_server-1.17.0[${PYTHON_USEDEP}]
+ <dev-python/notebook-7[${PYTHON_USEDEP}]
+ >=dev-python/notebook_shim-0.1.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ )
+ doc? (
+ virtual/pandoc
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source \
+ dev-python/sphinx_rtd_theme \
+ dev-python/nbsphinx \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/myst_parser \
+ dev-python/ipython_genutils
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # move /usr/etc stuff to /etc
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}