summaryrefslogtreecommitdiff
path: root/dev-python/nbclassic/nbclassic-0.3.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nbclassic/nbclassic-0.3.7.ebuild')
-rw-r--r--dev-python/nbclassic/nbclassic-0.3.7.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/nbclassic/nbclassic-0.3.7.ebuild b/dev-python/nbclassic/nbclassic-0.3.7.ebuild
deleted file mode 100644
index 1e6c6948383c..000000000000
--- a/dev-python/nbclassic/nbclassic-0.3.7.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_PEP517=jupyter
-inherit distutils-r1
-
-DESCRIPTION="Jupyter Notebook as a Jupyter Server Extension"
-HOMEPAGE="https://jupyter.org/"
-SRC_URI="https://github.com/jupyterlab/nbclassic/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- >=dev-python/jupyter_server-1.8[${PYTHON_USEDEP}]
- <dev-python/notebook-7[${PYTHON_USEDEP}]
- >=dev-python/notebook_shim-0.1.0[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
- dev-python/pytest-tornasync[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_install_all() {
- distutils-r1_python_install_all
- # move /usr/etc stuff to /etc
- mv "${ED}/usr/etc" "${ED}/etc" || die
-}