summaryrefslogtreecommitdiff
path: root/dev-python/mss/mss-8.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mss/mss-8.0.3.ebuild')
-rw-r--r--dev-python/mss/mss-8.0.3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/mss/mss-8.0.3.ebuild b/dev-python/mss/mss-8.0.3.ebuild
new file mode 100644
index 000000000000..46883a1b2162
--- /dev/null
+++ b/dev-python/mss/mss-8.0.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="An ultra fast cross-platform multiple screenshots module in python using ctypes"
+HOMEPAGE="
+ https://github.com/BoboTiG/python-mss/
+ https://pypi.org/project/mss/
+"
+
+LICENSE="MIT"
+SLOT="0"
+# test suite suddenly started segfaulting, TODO
+KEYWORDS=""
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme
+
+EPYTEST_IGNORE=(
+ # upstream tests for self-build, apparently broken by setuptools
+ # issuing deprecation warnings
+ mss/tests/test_setup.py
+)
+
+EPYTEST_DESELECT=(
+ # unreliable `lsof -U | grep ...` tests
+ mss/tests/test_leaks.py
+)
+
+src_prepare() {
+ sed -i -e '/--cov/d' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}