summaryrefslogtreecommitdiff
path: root/dev-python/mpmath
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mpmath')
-rw-r--r--dev-python/mpmath/Manifest4
-rw-r--r--dev-python/mpmath/mpmath-1.3.0-r1.ebuild4
-rw-r--r--dev-python/mpmath/mpmath-1.4.0_alpha1.ebuild62
3 files changed, 67 insertions, 3 deletions
diff --git a/dev-python/mpmath/Manifest b/dev-python/mpmath/Manifest
index f225c703662b..191d6af9b820 100644
--- a/dev-python/mpmath/Manifest
+++ b/dev-python/mpmath/Manifest
@@ -1,3 +1,5 @@
DIST mpmath-1.3.0.tar.gz 508106 BLAKE2B 9d4eebbbb6788dd3ee45c8c30068ef3512043dd09ab626cbaf69b0f6bdf057a6e8c53c34e3dda7627db923f0d536a0bebf83916d8942f4dde9546bb8e0046f33 SHA512 a68028150095d743eae9669a0f70cbe6b7bcb4d27dfad6b1a96575f0885ec7306459a2a464117bab18779883ee8b4293502b4bd0ebd8672767e1d08d38f8b202
-EBUILD mpmath-1.3.0-r1.ebuild 835 BLAKE2B 04891d93119b8ca528ed3c5ee95f8ddd0a1339b879389c157e339ef03ec4abce8ff994acc63fbca439edd4765e369f586f0cdc4038b72275af790ccfb5fa87b6 SHA512 10dc2787765a731390c8ab894001b8dd78396b21b7d21ba1a9c585be360cbe80d81a2daddc8ab8189f4c6708e39db58ce591850f448424920a2fdcc2b0936c7a
+DIST mpmath-1.4.0a1.tar.gz 2063946 BLAKE2B 0c6a86b1c8dc9addc3eb82586d4c4182ae6a9318cbe45d4fc699b9fbf9539774ae30f11c2d50137a3aa16ed4b0c328990483c2ceea812f86751cfa3ce419de5c SHA512 260afb20faaa949b89054ced3b039e346086d47c6ea018c8d226a0c42d9aa8f792611fe709c894a0df6930a0703dc8cfcf814432eba7ac977a821effd8879903
+EBUILD mpmath-1.3.0-r1.ebuild 855 BLAKE2B 9a51290a8a128467afe77eff887190deaee0327fc175541d316f6c62aef777567e53c7884342ac6082ad5a9eab7081a75a1c7b4dd3090f6cd2f5efe2f85aafb1 SHA512 21ec5b38e62a62dad3907d3828a29221e93c9d86f5fc6284881a5863f82b499d7f0ed3f488c08b31de274d24220d6280571bafdc0abebac36fd24b2cf2c6a019
+EBUILD mpmath-1.4.0_alpha1.ebuild 1749 BLAKE2B b77d6f0822cac3b1bb5a4185fbb2aebe7be7673cadf5067d04e16838af79092490d53e28fcbaf250d48b7365b7f65a73e7cca9a7461fe42e105f1babf24dd7f0 SHA512 f350e1dc36076d00d2f0bffe22d1d0be2f26bf09882b8d8c6a3db4a7e488265c73a6abbf0d0409734307436310cbc81adb670a91bb50b20f85a31c17aacfda9a
MISC metadata.xml 624 BLAKE2B 8526d1f6329f8cb4d2ee5a9ae73dc5bf3861adce5beaa6a0aaf5abb918de11ad1ab0c5c206331bd4eaeaa7bdeda0c6ea6a2007492825be0545caa121f41abd6c SHA512 dc4c6f5e82ce735e70bdc1bbfbc01f9c1d62c2d46c54a173287a59b90882aa09945da39bb41e7b28f6d0066851e2adf07f0b7033aa77cc5620491864e89f188e
diff --git a/dev-python/mpmath/mpmath-1.3.0-r1.ebuild b/dev-python/mpmath/mpmath-1.3.0-r1.ebuild
index d4c725b40085..814e9686c59d 100644
--- a/dev-python/mpmath/mpmath-1.3.0-r1.ebuild
+++ b/dev-python/mpmath/mpmath-1.3.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,7 +17,7 @@ HOMEPAGE="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+KEYWORDS="amd64 arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
distutils_enable_tests pytest
diff --git a/dev-python/mpmath/mpmath-1.4.0_alpha1.ebuild b/dev-python/mpmath/mpmath-1.4.0_alpha1.ebuild
new file mode 100644
index 000000000000..6404b6fadcbc
--- /dev/null
+++ b/dev-python/mpmath/mpmath-1.4.0_alpha1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Python library for arbitrary-precision floating-point arithmetic"
+HOMEPAGE="
+ https://mpmath.org/
+ https://github.com/mpmath/mpmath/
+ https://pypi.org/project/mpmath/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/gmpy[${PYTHON_USEDEP}]
+ ' 'python3*')
+ $(python_gen_cond_dep '
+ dev-python/ipython[${PYTHON_USEDEP}]
+ ' 3.{10..12})
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ mpmath/tests/test_cli.py::test_bare_console_bare_division
+ mpmath/tests/test_cli.py::test_bare_console_no_bare_division
+ mpmath/tests/test_cli.py::test_bare_console_pretty
+ mpmath/tests/test_cli.py::test_bare_console_without_ipython
+ mpmath/tests/test_cli.py::test_bare_console_wrap_floats
+ # precision problems on some arches, also np2
+ # https://github.com/mpmath/mpmath/pull/816
+ # https://github.com/mpmath/mpmath/issues/836
+ mpmath/tests/test_convert.py::test_compatibility
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p rerunfailures --reruns=5
+}
+
+pkg_postinst() {
+ optfeature "gmp support" dev-python/gmpy
+ optfeature "matplotlib support" dev-python/matplotlib
+}