summaryrefslogtreecommitdiff
path: root/dev-python/mpdlcd/mpdlcd-0.5.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mpdlcd/mpdlcd-0.5.2-r1.ebuild')
-rw-r--r--dev-python/mpdlcd/mpdlcd-0.5.2-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/mpdlcd/mpdlcd-0.5.2-r1.ebuild b/dev-python/mpdlcd/mpdlcd-0.5.2-r1.ebuild
new file mode 100644
index 000000000000..4acf00858c18
--- /dev/null
+++ b/dev-python/mpdlcd/mpdlcd-0.5.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A small tool to display the MPD status on a LCDproc server"
+HOMEPAGE="https://github.com/rbarrois/mpdlcd"
+SRC_URI="https://github.com/rbarrois/${PN}/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="dev-python/python-mpd"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman man/mpdlcd.1
+
+ insinto /etc
+ doins mpdlcd.conf
+
+ newinitd "${FILESDIR}"/mpdlcd.initd mpdlcd
+ newconfd "${FILESDIR}"/mpdlcd.confd mpdlcd
+}