summaryrefslogtreecommitdiff
path: root/dev-python/mmh3/mmh3-2.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mmh3/mmh3-2.5.1.ebuild')
-rw-r--r--dev-python/mmh3/mmh3-2.5.1.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/mmh3/mmh3-2.5.1.ebuild b/dev-python/mmh3/mmh3-2.5.1.ebuild
new file mode 100644
index 000000000000..20612ee438c5
--- /dev/null
+++ b/dev-python/mmh3/mmh3-2.5.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Python library for MurmurHash3, fast and robust hash functions."
+HOMEPAGE="https://pypi.org/project/mmh3/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="CC0-1.0 public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"