summaryrefslogtreecommitdiff
path: root/dev-python/mkdocstrings
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mkdocstrings')
-rw-r--r--dev-python/mkdocstrings/Manifest2
-rw-r--r--dev-python/mkdocstrings/mkdocstrings-0.23.0.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/mkdocstrings/Manifest b/dev-python/mkdocstrings/Manifest
index 05e4efcd9d20..d4fcd1b46653 100644
--- a/dev-python/mkdocstrings/Manifest
+++ b/dev-python/mkdocstrings/Manifest
@@ -1,3 +1,5 @@
DIST mkdocstrings-0.22.0.gh.tar.gz 81345 BLAKE2B ee2bcc0084c5d17368bc1a04db2f097f997872b38fd6b3d32f7daaefe78a496bb0a23d6588458a65b827954382e11c6b6d81baa2117af4b3341e9e727c616ca0 SHA512 c6226d50aaf029a139f51bb1f7101446e11a3e1337f7cd1c9324a2e258753cf25911b2da7042a08a64ae4cf51987b0b2a6ab752af408cdb54d436bcc908d66ff
+DIST mkdocstrings-0.23.0.gh.tar.gz 80975 BLAKE2B fb561b46f98372093846d28890b3d7e1a65f89007a6d321c08535eeefc82ee9c06d447c594a53ef2109ed58286d8e1a8202e1678f77328c3ec5a3150bfc129ea SHA512 e1d9be20691f2272d64d746dd6af8c152f7d6eabef1e6c03f7e0b36af4e04591a8d878d036c0bb448483759311abc652db09e5b705569ddb83f81ad785ad5005
EBUILD mkdocstrings-0.22.0.ebuild 1593 BLAKE2B 5339b28197469a2494b8ee767267c335c4ab78d7e2fa74486cc9906cceb1db84d343332290a051c404d0dfd73805776c6e016737f197ff1bc8811182eb36196f SHA512 73ea512110294cb4a62245b08608b4bf86deb9ca7692ecf1ede3d4235f76e506a1e9b52739f62d5b688772dc079fcb6e0073fd5d7a6cb3e700b988d819d8d2ba
+EBUILD mkdocstrings-0.23.0.ebuild 1593 BLAKE2B 3d3e7d38298a3c0d10c8242116abc36d58b826265df239c4ac8be150e5ca864bae60511d2dedb2b40291d3a58b6f6334b08c241464c691eed1affc6c91b23196 SHA512 67ef853888ec81c7a9a3fba0d9e58032a50e7d8af2ca927cad4c07fecb6094b07ed9ba78f3f4856c4dc582006f8dfd8e207c991048155a0691f07c521795ae2f
MISC metadata.xml 410 BLAKE2B 896cd2e10ca1ef3d76b5cf37b5f2a89f12df1f068a5a423c27e51e4f1d60261ed0198ee11ca0b838cae0dfd2891e3ea7ffbe071d72c69f9f83a89ae42ae656a9 SHA512 3b2e9deab0dc2f17bc6e2e5c25e5b27c084cc5027fae2f84b31f16da9409fc28bbc75a6ea0ee96bb51555e6e61275a472bf7d0c1b2ae4a4d8ca469f0d0280660
diff --git a/dev-python/mkdocstrings/mkdocstrings-0.23.0.ebuild b/dev-python/mkdocstrings/mkdocstrings-0.23.0.ebuild
new file mode 100644
index 000000000000..1f12e1c46f72
--- /dev/null
+++ b/dev-python/mkdocstrings/mkdocstrings-0.23.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatic documentation from sources, for MkDocs"
+HOMEPAGE="
+ https://mkdocstrings.github.io/
+ https://github.com/mkdocstrings/mkdocstrings/
+ https://pypi.org/project/mkdocstrings/
+"
+# Tests require files absent from PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/mkdocstrings/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/jinja-2.11.1[${PYTHON_USEDEP}]
+ >=dev-python/markdown-3.3[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-1.1[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.5[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-autorefs-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pymdown-extensions-6.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ dev-python/mkdocstrings-python[${PYTHON_USEDEP}]
+ )
+"
+
+# mkdocstrings documentation generation requires several currently
+# unpackaged mkdocs extensions and plug-ins, and this test
+# makes use of mkdocs configuration
+EPYTEST_DESELECT=(
+ tests/test_plugin.py::test_disabling_plugin
+ # WTF, it tries to unlink installed files from installed package?!
+ tests/test_handlers.py::test_extended_templates
+ # TODO: package markdown-exec
+ tests/test_inventory.py::test_sphinx_load_mkdocstrings_inventory_file
+ # Internet
+ tests/test_inventory.py::test_load_inventory
+)
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}