summaryrefslogtreecommitdiff
path: root/dev-python/mkdocs-git-authors-plugin
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mkdocs-git-authors-plugin')
-rw-r--r--dev-python/mkdocs-git-authors-plugin/Manifest2
-rw-r--r--dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.8.0.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/mkdocs-git-authors-plugin/Manifest b/dev-python/mkdocs-git-authors-plugin/Manifest
index 84ca56f2a1f1..36eb9ff20764 100644
--- a/dev-python/mkdocs-git-authors-plugin/Manifest
+++ b/dev-python/mkdocs-git-authors-plugin/Manifest
@@ -1,3 +1,5 @@
DIST mkdocs-git-authors-plugin-0.7.2.gh.tar.gz 29300 BLAKE2B a93e87cde212fe15c1986bfdeeef207637b1bb10de1f864b0014b6dc0c74a64dbe152eae33c176adbb0e148cebd15717a307f874fd218e638835ce0687de14d8 SHA512 6fdaa7d06f0f0326b4123be546f0ad78ee3769a0048528e866b5c787ccaad9ba33e9c47b3597eea5b43d91f949d07b5cae9eca167b12978c7f577314e55c2721
+DIST mkdocs-git-authors-plugin-0.8.0.gh.tar.gz 30080 BLAKE2B 08c0eee392ef94caf30f176f5c8923b4e3c5d951a36348bbeec4396052ee492715b99aa4f8824348728296e5276747083340943bd21f7850abd0ccfb3a2bf12c SHA512 4620c8cccf69eb8ec3010ac7483a3df1ab43bcf8e0837399f46383d9947fdddc0c70d7d8405c820f1cb4b773724ca7006f2cc3bdd5559c107a2db8e3ceb8b38e
EBUILD mkdocs-git-authors-plugin-0.7.2.ebuild 1302 BLAKE2B 25b9ecc1b7bcb7f863d94daef8e013021f3f2a0b2ede655a2df4988d41fce6f41aa613677decf77a4a3c098caf4223734ff22aab7d756361c93602aa6e854f86 SHA512 f437998b47f7b5e7957d28243810f124408d2b4559fbb279acc7cb997e19e16230827244dba7ebadf7496065c1cb237b33dee5fa6faa082be715d3d38cf103db
+EBUILD mkdocs-git-authors-plugin-0.8.0.ebuild 1305 BLAKE2B ec58df2bb645e7028c356282897e2c3bcffd18a1491e21f5730265812ad8bde1577451ae99c1b5d77002c0988b9420139716db7b2cc7e06bd65e4c9eaf72c304 SHA512 92a0fca2e1cc8c4181d4b0b986e2419463a885db33c3ebaa1e23c98f72bf464c50d3bf5fa5e1cb8985404425111458df0a11ffac93ddd4d2674f1130ed05c954
MISC metadata.xml 564 BLAKE2B cee03d6742cb66a51c92f8999483f6c04c2b3fc7e8b88f5882bbabc577a54e922bdccf8a1a467e601c43511a372ac90ff8aa4500bd95715cffa83214ee2e64e9 SHA512 2b5539fff2990ebd293715b659e7b9bdeb63117c35933f49a21b873b45188476d3d44f6ac5b1656ee598f028e80f648b91b36ef4dae3f900705dbe2a7355356e
diff --git a/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.8.0.ebuild b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.8.0.ebuild
new file mode 100644
index 000000000000..919c58515e2b
--- /dev/null
+++ b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.8.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{10..12} )
+
+# Requires self to be installed to build docs
+# TODO: Do this a bit better
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ dev-python/regex
+ dev-python/mkdocs-material
+ dev-python/mkdocs-git-authors-plugin
+"
+DOCS_INITIALIZE_GIT=1
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Mkdocs plugin to display git authors of a page"
+HOMEPAGE="
+ https://github.com/timvink/mkdocs-git-authors-plugin/
+ https://pypi.org/project/mkdocs-git-authors-plugin/
+"
+SRC_URI="https://github.com/timvink/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+# Tests are broken outside of upstream git repo
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ dev-python/mkdocs-git-revision-date-localized-plugin[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # mkdocs-git-authors tests need git repo
+ use test && initialize_git_repo
+
+ distutils-r1_python_prepare_all
+}