summaryrefslogtreecommitdiff
path: root/dev-python/mkdocs-get-deps/mkdocs-get-deps-0.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mkdocs-get-deps/mkdocs-get-deps-0.2.0.ebuild')
-rw-r--r--dev-python/mkdocs-get-deps/mkdocs-get-deps-0.2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/mkdocs-get-deps/mkdocs-get-deps-0.2.0.ebuild b/dev-python/mkdocs-get-deps/mkdocs-get-deps-0.2.0.ebuild
new file mode 100644
index 000000000000..f5d189fa2469
--- /dev/null
+++ b/dev-python/mkdocs-get-deps/mkdocs-get-deps-0.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="extension that lists all dependencies according to a mkdocs.yml file"
+HOMEPAGE="
+ https://github.com/mkdocs/get-deps/
+ https://pypi.org/project/mkdocs-get-deps/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+RDEPEND="
+ >=dev-python/mergedeep-1.3.4[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest