summaryrefslogtreecommitdiff
path: root/dev-python/mkautodoc/mkautodoc-0.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mkautodoc/mkautodoc-0.2.0.ebuild')
-rw-r--r--dev-python/mkautodoc/mkautodoc-0.2.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/mkautodoc/mkautodoc-0.2.0.ebuild b/dev-python/mkautodoc/mkautodoc-0.2.0.ebuild
new file mode 100644
index 000000000000..f5e837d4c962
--- /dev/null
+++ b/dev-python/mkautodoc/mkautodoc-0.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Auto documentation for MkDocs"
+HOMEPAGE="
+ https://github.com/tomchristie/mkautodoc/
+ https://pypi.org/project/mkautodoc/
+"
+SRC_URI="https://github.com/tomchristie/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/markdown[${PYTHON_USEDEP}]"
+
+BDEPEND="test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+
+src_test() {
+ local -x PYTHONPATH="${WORKDIR}/${P}/tests/mocklib:${WORKDIR}/${P}"
+ distutils-r1_src_test
+}