summaryrefslogtreecommitdiff
path: root/dev-python/micawber/micawber-0.5.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/micawber/micawber-0.5.4-r1.ebuild')
-rw-r--r--dev-python/micawber/micawber-0.5.4-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/micawber/micawber-0.5.4-r1.ebuild b/dev-python/micawber/micawber-0.5.4-r1.ebuild
new file mode 100644
index 000000000000..4732cd4e2b88
--- /dev/null
+++ b/dev-python/micawber/micawber-0.5.4-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A small library for extracting rich content from urls"
+HOMEPAGE="
+ https://github.com/coleifer/micawber/
+ https://pypi.org/project/micawber/
+"
+SRC_URI="
+ https://github.com/coleifer/micawber/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" runtests.py || die "Tests failed with ${EPYTHON}"
+}