summaryrefslogtreecommitdiff
path: root/dev-python/meson-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/meson-python')
-rw-r--r--dev-python/meson-python/Manifest2
-rw-r--r--dev-python/meson-python/meson-python-0.12.1.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/meson-python/Manifest b/dev-python/meson-python/Manifest
index 9b2421c5e07c..8a7aac39ebfc 100644
--- a/dev-python/meson-python/Manifest
+++ b/dev-python/meson-python/Manifest
@@ -1,4 +1,6 @@
AUX meson-python-0.11.0-defaults.patch 608 BLAKE2B b4c8d87a766495ee644830dd98903e512e052ccb0c31b75ef755b2b33cc7b912ea3b232b66c539ec3da8d8d77ae90b04a87cac8d0c55cde4c00c0f32ca4cb001 SHA512 f814d2c93bdb14e245b83eb4a94329875ccaed2f9a78fb31ae5c5bc5b778bd25b22b097bbc5dbd810029b9613a2532d1ab971c8bb6c60cda41ad6d1351c9e93a
DIST meson-python-0.12.0.gh.tar.gz 43801 BLAKE2B fa4f5b73d490fce64da5c9f79c590e32af5b39790c0ffddc694a6b11a9274760a4e92a3d45abdefdbec1e6c5235ae799ee6c3e1b99685028b3bc007d5322683d SHA512 f2e416027bb6fb6cf6ad0fd84c6b65ddc83b497ff96b5a144dfcdd1addee44972eaa7422c8d9a8092431b6df1b052f970e9e7bd7dc57b28fbf42d2ea3a8d9231
+DIST meson-python-0.12.1.gh.tar.gz 43855 BLAKE2B 96b9ff5ef628bb471f7f79ce30ec6f3f851ce0006327e8b3a6003fdcb768f3280c0ee882d1c0c8ea183b0f2319d7c977c3fbb62742e3127bafb73e9732b3a1a9 SHA512 6f8e840da0155f2dd0e7139387f875cfad79eb042abcfa69b3043f51cbae3222fc2986e13798389909a0b4719513c93af381ec00a69fdfedf14bbe4e100b2f08
EBUILD meson-python-0.12.0.ebuild 1659 BLAKE2B beae539434ee07d0de931e57b78e4b5039020b4974090e358b2731c334274e2b8c9318dda9d46173bad6d3936ec2b286b1178eb169fe5e14ed43cdb946d4dd2c SHA512 40567b0155f786d09acbe57f0c1fe33e65abc4323ce52360b245236c8e90fced7f97ee43abfabae388b9d18c3f8c93affd83860ce7cd6f908b7282de2235b226
+EBUILD meson-python-0.12.1.ebuild 1454 BLAKE2B 205e8bacaec7055610c4b688730e57bbb4bd593722e5b93459a914abe98248cbfd45444d488c5a1a2363471339d0aa4aa771d7b3f324d3170e157ffb7662cb46 SHA512 836acdc1c59c1761a063b6f505288a54230dbed1c0e50a4b637aa736f68e651aa9b13303a70a6fb48fa99912b3ff1fd55e7a209e856373010592462680ff5e21
MISC metadata.xml 357 BLAKE2B c2b5fd8c6ad39e92970a5e6c1db8950b4850660c9a95a84063504ab75e5dd69e3ab844fcef23cb51f33493b7e522a6d26227ff48dd893c92c422badc70f3c962 SHA512 1402ace4da543de7320a1d97f44177593807d5be9f1891d8a53190581877569508c46fe6b4ce63516c7fee2d2165d59d39f44343dde18438570883da3f4ad28c
diff --git a/dev-python/meson-python/meson-python-0.12.1.ebuild b/dev-python/meson-python/meson-python-0.12.1.ebuild
new file mode 100644
index 000000000000..07fb16ba0821
--- /dev/null
+++ b/dev-python/meson-python/meson-python-0.12.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Meson PEP 517 Python build backend"
+HOMEPAGE="
+ https://pypi.org/project/meson-python/
+ https://github.com/mesonbuild/meson-python/
+"
+SRC_URI="
+ https://github.com/mesonbuild/meson-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pyproject-metadata-0.6.1[${PYTHON_USEDEP}]
+ >=dev-util/meson-0.63.0[${PYTHON_USEDEP}]
+ dev-util/patchelf
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.11.0-defaults.patch
+)
+
+distutils_enable_sphinx docs \
+ dev-python/furo \
+ dev-python/sphinx-autodoc-typehints
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires network access
+ tests/test_pep518.py::test_pep518
+)
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires network access
+ tests/test_pep518.py::test_pep518
+ )
+ unset NINJA
+
+ epytest
+
+ rm -rf docs/examples/spam/build/ || die # remove artifacts
+}