summaryrefslogtreecommitdiff
path: root/dev-python/memory_profiler/memory_profiler-0.54.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/memory_profiler/memory_profiler-0.54.0.ebuild')
-rw-r--r--dev-python/memory_profiler/memory_profiler-0.54.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/memory_profiler/memory_profiler-0.54.0.ebuild b/dev-python/memory_profiler/memory_profiler-0.54.0.ebuild
new file mode 100644
index 000000000000..905633999611
--- /dev/null
+++ b/dev-python/memory_profiler/memory_profiler-0.54.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module for monitoring memory usage of a python program"
+HOMEPAGE="https://pypi.org/project/memory_profiler/ https://github.com/fabianp/memory_profiler"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} -m memory_profiler test/test_func.py || die
+ ${EPYTHON} -m memory_profiler test/test_loop.py || die
+ ${EPYTHON} -m memory_profiler test/test_as.py || die
+ ${EPYTHON} -m memory_profiler test/test_global.py || die
+ ${EPYTHON} -m memory_profiler test/test_precision_command_line.py || die
+ ${EPYTHON} -m memory_profiler test/test_gen.py || die
+ if python_is_python3; then
+ ${EPYTHON} -m memory_profiler test/test_unicode.py || die
+ fi
+ ${EPYTHON} test/test_tracemalloc.py || die
+ ${EPYTHON} test/test_import.py || die
+ ${EPYTHON} test/test_memory_usage.py || die
+ ${EPYTHON} test/test_precision_import.py || die
+}