summaryrefslogtreecommitdiff
path: root/dev-python/mechanize/mechanize-0.4.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mechanize/mechanize-0.4.9.ebuild')
-rw-r--r--dev-python/mechanize/mechanize-0.4.9.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/mechanize/mechanize-0.4.9.ebuild b/dev-python/mechanize/mechanize-0.4.9.ebuild
index 9f450d7fd6b3..801db8146541 100644
--- a/dev-python/mechanize/mechanize-0.4.9.ebuild
+++ b/dev-python/mechanize/mechanize-0.4.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -29,6 +29,11 @@ BDEPEND="
)
"
+PATCHES=(
+ # https://github.com/python-mechanize/mechanize/pull/95
+ "${FILESDIR}/${P}-test.patch"
+)
+
python_test() {
- "${EPYTHON}" run_tests.py || die
+ "${EPYTHON}" run_tests.py -v || die
}