summaryrefslogtreecommitdiff
path: root/dev-python/matplotlib-inline
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/matplotlib-inline')
-rw-r--r--dev-python/matplotlib-inline/Manifest2
-rw-r--r--dev-python/matplotlib-inline/matplotlib-inline-0.1.7.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/matplotlib-inline/Manifest b/dev-python/matplotlib-inline/Manifest
index 893cd14b1f92..d9e0cfa7d6c7 100644
--- a/dev-python/matplotlib-inline/Manifest
+++ b/dev-python/matplotlib-inline/Manifest
@@ -1,3 +1,5 @@
DIST matplotlib-inline-0.1.6.gh.tar.gz 7526 BLAKE2B fd8fde8e218e19fdf7a09bd7f36abd2e4422ed7de8ed8e2d6e52d995e76b62d8e60223fc43a243f2a0ca545037b44ead9520b67cf54b173d95389eb401b17e9a SHA512 7d34f5a86d65d7a2017cf924dc363d7578d1eb14943c3de56e5a0ac79d92d674b387c5528ea76e9e11e0193e71d8cd1315ceb517e9c9678c41ed412e8fd42c04
+DIST matplotlib-inline-0.1.7.gh.tar.gz 8112 BLAKE2B 1c1dc0f0d5a86dc5e8fae013f569f16c90466765643a7c2ef7359f906bec18bbe4bd27502cef78a3edc4f3a617416389648cbb9abab75ba804fbce85de838cec SHA512 b424b42c221227fe8807a4c56207aa3f0830cd857b816e278d4d22a57091598b9a4f3de5f046d9e8722a6cae13a8f187ffc24927071592ff514b1add3962d03f
EBUILD matplotlib-inline-0.1.6-r1.ebuild 1070 BLAKE2B 1d59c54541f33031b290b1627190b6011dac1ce940eb9fa725483150ee5794bda5a835676bc02892b508f0ecd443b82098fac8d4691328252f6e9ad0381f1573 SHA512 8619fb338174835b9e63080d95f4eeebcd2e8332fd7c47849fe8c300eb8fefe92ffd2299f3538637710d9dcd84181de0f24ba27bff6994770670069362084520
+EBUILD matplotlib-inline-0.1.7.ebuild 1078 BLAKE2B a94ec65620d32d6c4318985c273bcf108b79d6a32465337f6deb8ea22f95f7f53c5bb2587fd08ba55fccd9bbd92f0f77c4dab1b1823c68a4cb5888a7a4c16865 SHA512 5d225f6f45d512010c0a7e6572c02e150f271bbf364700ed15c4e5ba37f2c9acea07b4a2208f786d5e55646007fd64b6b751b8e2e15373a428605296055a7044
MISC metadata.xml 388 BLAKE2B 2c15ea9d7f572bfd693b7b715ad5d32b0528889b07e7b7d2b58e2f99d1884acf376ed5bcbcf527179b232bc761c3aa31a59b112acd7b3a82f07f19d2592d167d SHA512 a40bc579234e3f6f4cb7cf12c0851ff23be0e9a2af94af099d503214f626d03a26dff3fc5d1aebedb5c3b4adfb13f1b6fb72ec10d62d3fea6bc2772271cea027
diff --git a/dev-python/matplotlib-inline/matplotlib-inline-0.1.7.ebuild b/dev-python/matplotlib-inline/matplotlib-inline-0.1.7.ebuild
new file mode 100644
index 000000000000..826a7275b5ac
--- /dev/null
+++ b/dev-python/matplotlib-inline/matplotlib-inline-0.1.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Inline Matplotlib backend for Jupyter"
+HOMEPAGE="
+ https://github.com/ipython/matplotlib-inline/
+ https://pypi.org/project/matplotlib-inline/
+"
+SRC_URI="
+ https://github.com/ipython/matplotlib-inline/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+# Although in theory we could depend on matplotlib, upstream does not.
+# This is because the sole purpose of the package is to be loaded by
+# ipython (also not a dependency!) as a response to interactive use of
+# the "%matplotlib" magic.
+#
+# In order to be seamless and straightforward, this backend is always
+# installed and just requires users using matplotlib, to install
+# matplotlib before importing and using it.
+RDEPEND="
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"