summaryrefslogtreecommitdiff
path: root/dev-python/marshmallow
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/marshmallow')
-rw-r--r--dev-python/marshmallow/Manifest2
-rw-r--r--dev-python/marshmallow/marshmallow-3.21.3.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index 839a354bccd7..0bd79880bd4a 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1,3 +1,5 @@
DIST marshmallow-3.21.2.gh.tar.gz 183818 BLAKE2B 01e14514d836c36c9f24a6e0a527271bd17ea5ce1ce35cabb6200a886c85ef970e7d54191307d1580568f05b501ec6028c7f126475ac64c160fec75c247a4c20 SHA512 b151f7e712dc5dd5d7f592942a6a4b09d462b684f542406c8bc57237e4b2402eb287d02e4ca2ef65e10dccb1e200b9ff8ae24f69160af1c6aa02fc5dfdc9eeba
+DIST marshmallow-3.21.3.gh.tar.gz 183813 BLAKE2B c5b0165be783e87149c1f1b7f0e370c0c0b33cd5e34b0a91b1510b81e840ca1f87c34b13f00e0c22b5a34d8fec62bba4a66f889a450a4f03fda7a85a63bf71bf SHA512 522d015d4207b1258ef92901f106f94bd412e011c26ad074ca9ee3156e51a1d873063f0ebd24b613cd95f34397f29e79358bb420ee0eef51095e6e8858d61fca
EBUILD marshmallow-3.21.2.ebuild 774 BLAKE2B 8b1d18c186a3ddef72b3c1b899579bde66771413a1a5f2e17cf4521dafb4d9ce69ad4f5413a554e452966fe6a5364503ae9a5af1362c824cc6d4ab0860285a01 SHA512 48651280a575c241a1ebe6f25f1feb6320269b32f86a6527e54ecf5b45dc307c354dc235e78b1334927a8584765e150693920b34a2655dff0dd574911eadb76d
+EBUILD marshmallow-3.21.3.ebuild 774 BLAKE2B 8b1d18c186a3ddef72b3c1b899579bde66771413a1a5f2e17cf4521dafb4d9ce69ad4f5413a554e452966fe6a5364503ae9a5af1362c824cc6d4ab0860285a01 SHA512 48651280a575c241a1ebe6f25f1feb6320269b32f86a6527e54ecf5b45dc307c354dc235e78b1334927a8584765e150693920b34a2655dff0dd574911eadb76d
MISC metadata.xml 462 BLAKE2B 8092c0a0e4a28fdedd16131788e41c7133a7d114b6603c859a7b75a3e2c1519e51450c6ecd8b8bb42b16feee2b187d61a3241c4af6a4decebe85cd011944271d SHA512 bc243259fe7e0cf4892a8e9d5bc9792cdf9166400e6c5a2bb00dda58a1a4eae672c9b5c9723ba662f583bf47b994134943d6879141472e9ca4395d8700649997
diff --git a/dev-python/marshmallow/marshmallow-3.21.3.ebuild b/dev-python/marshmallow/marshmallow-3.21.3.ebuild
new file mode 100644
index 000000000000..f7d269422f0f
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.21.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for converting to and from native Python datatypes"
+HOMEPAGE="
+ https://github.com/marshmallow-code/marshmallow/
+ https://pypi.org/project/marshmallow/
+"
+SRC_URI="
+ https://github.com/marshmallow-code/marshmallow/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-17.0[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest