summaryrefslogtreecommitdiff
path: root/dev-python/marshmallow/marshmallow-3.12.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/marshmallow/marshmallow-3.12.1.ebuild')
-rw-r--r--dev-python/marshmallow/marshmallow-3.12.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/marshmallow/marshmallow-3.12.1.ebuild b/dev-python/marshmallow/marshmallow-3.12.1.ebuild
new file mode 100644
index 000000000000..97790c85ad17
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.12.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for converting to and from native Python datatypes"
+HOMEPAGE="https://github.com/marshmallow-code/marshmallow/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest