summaryrefslogtreecommitdiff
path: root/dev-python/markdown-include
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/markdown-include')
-rw-r--r--dev-python/markdown-include/Manifest3
-rw-r--r--dev-python/markdown-include/markdown-include-0.8.1.ebuild25
-rw-r--r--dev-python/markdown-include/metadata.xml13
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/markdown-include/Manifest b/dev-python/markdown-include/Manifest
new file mode 100644
index 000000000000..c9f8eee14692
--- /dev/null
+++ b/dev-python/markdown-include/Manifest
@@ -0,0 +1,3 @@
+DIST markdown-include-0.8.1.tar.gz 21873 BLAKE2B 83090f66af6f6b7dfc441bce97a0ca91bed3f94274030297e5f46fe8d42d3b3e83afc9f981941870f5bf361bfb5edd54bdda4c5d85595cc5599375f5a2478490 SHA512 4ae155d7e114de9d8ca32c129fe5778e7fc9516321357d8e4d90fad651a1dcb54b1fb144bc51e981cf728f1632dc293ed8cc1e7d4219154a2350780ea6f9b7b2
+EBUILD markdown-include-0.8.1.ebuild 605 BLAKE2B 23e15ea5dccab0272b0ec1806ccfc1b473e2ed73b8027b26bba9e4bee6050516bbd8855c2a5a4edaa8874548cdcc7b82a2e4d24fe903161b35e052e8342db342 SHA512 94f421478a8e35860dac610e6249c4659e919ece53fdbed4cb1019eeecd39d43f3dd5bb004f85a59b1fb3e07b36da75f888f63d13218e635b98c440a0d3bb855
+MISC metadata.xml 416 BLAKE2B 5955027f29795eabdf226a855c0ebe628de0d0105a1fe63a20511478ccd37289323fb857a303fc20e1b0922a786573dd1717dacdb01798939885017665d349fe SHA512 3139645f87e3b912ec75425d95f39fb0fcd37b6ab66d0ecda04391f94a093bd20a32d12d9dbc295fd26da679c34e7160713333f99ce16dddb742ee96ae3306b0
diff --git a/dev-python/markdown-include/markdown-include-0.8.1.ebuild b/dev-python/markdown-include/markdown-include-0.8.1.ebuild
new file mode 100644
index 000000000000..1983e613780b
--- /dev/null
+++ b/dev-python/markdown-include/markdown-include-0.8.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python-Markdown extension providing LaTeX-style 'include' function"
+HOMEPAGE="
+ https://github.com/cmacmackin/markdown-include
+ https://pypi.org/project/markdown-include/
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/markdown-3.0[${PYTHON_USEDEP}]"
+BDEPEND=">=dev-python/setuptools-scm-6.2[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
diff --git a/dev-python/markdown-include/metadata.xml b/dev-python/markdown-include/metadata.xml
new file mode 100644
index 000000000000..c4718378d4c5
--- /dev/null
+++ b/dev-python/markdown-include/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">markdown-include</remote-id>
+ <remote-id type="github">cmacmackin/markdown-include</remote-id>
+ </upstream>
+</pkgmetadata>