summaryrefslogtreecommitdiff
path: root/dev-python/markdown-include/markdown-include-0.8.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/markdown-include/markdown-include-0.8.1.ebuild')
-rw-r--r--dev-python/markdown-include/markdown-include-0.8.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/markdown-include/markdown-include-0.8.1.ebuild b/dev-python/markdown-include/markdown-include-0.8.1.ebuild
new file mode 100644
index 000000000000..1983e613780b
--- /dev/null
+++ b/dev-python/markdown-include/markdown-include-0.8.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python-Markdown extension providing LaTeX-style 'include' function"
+HOMEPAGE="
+ https://github.com/cmacmackin/markdown-include
+ https://pypi.org/project/markdown-include/
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/markdown-3.0[${PYTHON_USEDEP}]"
+BDEPEND=">=dev-python/setuptools-scm-6.2[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest