summaryrefslogtreecommitdiff
path: root/dev-python/manuel
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/manuel')
-rw-r--r--dev-python/manuel/Manifest3
-rw-r--r--dev-python/manuel/files/manuel-1.12.4-tests-python311.patch22
-rw-r--r--dev-python/manuel/manuel-1.12.4.ebuild40
3 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/manuel/Manifest b/dev-python/manuel/Manifest
index 59645f3d7e95..c20d8b544743 100644
--- a/dev-python/manuel/Manifest
+++ b/dev-python/manuel/Manifest
@@ -1,6 +1,3 @@
-AUX manuel-1.12.4-tests-python311.patch 793 BLAKE2B b5af04ad5b1508d35683e44c6fcfaf5c5d364c14f81d569c7971179a959c2eea98d70d077c45fa9473e4ae79f4a471f51e587c421588bb2e0795cbfc2cbd3c55 SHA512 1a89e91cbb63c5d040aa08afbb86e5fecf4fd8fb4d43079ac0fcb71d1e9d6cde7ba0c7eb042016e5e5eff8c594785662be3972c4667dc4e18ad7dcc1fa856eb8
-DIST manuel-1.12.4.tar.gz 45369 BLAKE2B e15f9261854fbad8ee1e1dc8645ec286a212c460a78fff1576b6886d8bf462ffe9a5484338fd9efc2bf053a7689e16b08de55f763ae319e66a363c5c28cf2a60 SHA512 cd65307f2ca94e66d88bc0c7c75702d49f505b358ebb812fd20906036ba10f2d1d11d2d69404b88c5f10b584dea05a988b5dc8ba07210b9d20ebd8a11b701633
DIST manuel-3f4d94d2ace3bdab4acad6896c93f5c96d6bee92.tar.gz 39774 BLAKE2B 7be5bad5ee39358e1b0229c02c86c9492cae09684d8a942b9f5dcf0afe31037f635295019306d404a1fb0b81e40bb523d194cc499a89b32600f1a330ddaf4d2d SHA512 f96fe6c9438b00d7562d64ead32ef84dcc4746281f066e4e7c175b1b274691ccd615c31e1d26fdc25a67e67d03f28b52182652921ab2c9ff365f59aaa475adaf
-EBUILD manuel-1.12.4.ebuild 761 BLAKE2B a644564e3cf43496af80d462edc1127ba1e5ead2bdad71e1c97734194f4958850031513f4d912ad060dba24b02b9a01c38610462a4e6956a77cdaa292d96b200 SHA512 daa7c386108b56fa45e65aeea98c9a01b8b875c3b7650d15875ae85594408e420a0f2dbd50a5ad51af64e881aed05b9b6de64093c72a927543cdb2de211eb671
EBUILD manuel-1.12.4_p20231129.ebuild 1073 BLAKE2B e396caa8c60b3fbbe41f11f9e72d979c9cb916358f28d3b4838b83a135d14080d3e9d9f7977ae33c176148c4a9049edb77fc6462056773e61c6fcf170f2f1aca SHA512 724e121a98f385f4c49af941c705c5d4d619109190ef5ef8a8bf30ff912995d782f46547de2768461fa99e8683e901686c003d34fd3a266c547364c84275130b
MISC metadata.xml 391 BLAKE2B 6b95f9d29d8df2b9f0cfd85012a7d751f443c3bc67f6254c376f8cd3c1c66e2972bc165edc8db6b5ef2851edf3e870cc2ca76d3f6f3c06daeb247ee349407f45 SHA512 ace493867fc08487876a55331b619a62b01e269d7b5307b2ae9e016d75ee9058f2e1354bd2e3243ef1b0cfff30cc3f8f661675e03c1ac07fb805f443b31c64ad
diff --git a/dev-python/manuel/files/manuel-1.12.4-tests-python311.patch b/dev-python/manuel/files/manuel-1.12.4-tests-python311.patch
deleted file mode 100644
index 5a6ef9dc3b7d..000000000000
--- a/dev-python/manuel/files/manuel-1.12.4-tests-python311.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-https://github.com/benji-york/manuel/pull/32
-
-From d9f12d03e39bb76e4bb3ba43ad51af6d3e9d45c0 Mon Sep 17 00:00:00 2001
-From: Matt Jolly <Matt.Jolly@footclan.ninja>
-Date: Mon, 6 Jun 2022 22:44:22 +1000
-Subject: [PATCH] Replace TextTestResult with TestResult for Py3.11
-
---- a/src/manuel/index.txt
-+++ b/src/manuel/index.txt
-@@ -211,10 +211,7 @@ When tests are run this way:
-
- >>> sys.stdout.writeln = lambda s: sys.stdout.write(s+'\n')
- >>> suite = loader.loadTestsFromTestCase(MyTest)
-- >>> result = suite.run(unittest.TextTestResult(sys.stdout, True, 3))
-- test1 (tests.MyTest) ... ok
-- test2 (tests.MyTest) ... ok
-- test3 (tests.MyTest) ... FAIL
-+ >>> result = suite.run(unittest.TestResult(True, 3))
-
- >>> for _, e in result.errors:
- ... print(e); print
-
diff --git a/dev-python/manuel/manuel-1.12.4.ebuild b/dev-python/manuel/manuel-1.12.4.ebuild
deleted file mode 100644
index 99f6fb6c3452..000000000000
--- a/dev-python/manuel/manuel-1.12.4.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Lets you mix and match traditional doctests with custom test syntax"
-HOMEPAGE="
- https://github.com/benji-york/manuel/
- https://pypi.org/project/manuel/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/zope-testing[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-tests-python311.patch
-)
-
-distutils_enable_tests setup.py
-
-src_prepare() {
- # unused rdep
- sed -e "/'setuptools'/d" -i setup.py || die
- distutils-r1_src_prepare
-}